Skip to main content
search
BankingComputer SecurityComputers, Computer Technology, Software

Infosec Partners provides SWIFT CSP Assessments

By January 5, 2022No Comments
SWIFT Customer Security Programme (CSP) Assessments

Infosec Partners is pleased to announce that we provide assessment support related to the SWIFT Customer Security Programme.

SWIFT is the world’s largest provider of secure financial messaging services to banks and other financial institutions, with more than 11,000 users in over 200 countries.

SWIFT’s Customer Security Programme (CSP) helps financial institutions ensure their defences against cyberattacks are up to date and effective. The CSP establishes a common set of security controls, the Customer Security Controls Framework (CSF), to help users secure their systems.

Each year SWIFT updates the security controls within the CSF, and all SWIFT users must apply these controls to their SWIFT-related infrastructure. In order to do so, SWIFT users must compare their security measures with those detailed in the CSF, and must attest their level of compliance annually with an annual independent assessment.

Infosec Partners is listed as an assessment provider in SWIFT directories*, helping financial organisations to assess compliance with the CSF controls.

We can also assist SWIFT users in evaluating their current cyber security framework, and in identifying measures to close any gaps between their security arrangements and the controls detailed in the SWIFT CSF.

Mark Oakton, Infosec Partners Security Director said “The security of the SWIFT system is paramount. This accomplishment represents our continued commitment to both professional certifications and compliance with industry standards, particularly within the financial sector which has become a very lucrative target for cyber attacks.”

For more information regarding SWIFT assessments contact the Infosec Partners team.

*SWIFT does not certify, warrant, endorse or recommend any service provider listed in its directory and SWIFT customers are not required to use providers listed in the directory.

Leave a Reply

Close Menu